Teza nr 6

  • Timp de lucru 60 minute
  • Toate subiectele sunt obligatorii și se acordă 1p din oficiu

 

6p Partea I

Să se facă un program în limbajul C  pentru următoarele cerințe.

1) Să se verifice dacă un graf neorientat este complet.

2) Să se verifice dacă o succesiune de vârfuri date este ciclu pentru un graf. In caz afirmativ, să se stabileasca daca este ciclu elementar sau nu.

3) Se citesc 2 grafuri neorientate, unul cu n noduri si m muchii, iar celalalt cu k varfuri si l muchii, ambele date prin vectorul muchiilor. Sa se determine daca al doilea graf este subgraf al primului.

 

4p Partea a II-a

1.) Considerand ca variabilele intregi au valorile a=30,b=25,c=30,care dintre aceste variabile isi va modifica valoarea in urma executarii instructiunii urmatoare?

 

if a<b then if a<c then b:=10

else c:=100;

  1. a) variabila b b)variabila c c) variabila a   d) nici una

 

2.) Care trebuie sa fie valoarea variabilei I pentru ca in urma executarii instructiuniiurmatoare, pe ecran sa fie afisata secventa de caractere ***** ?

 

while i*5<1000 do begin

write(‘*’);

i:=i*2+10;

end.

a)-5    b)-4  c)5  d)3  e)7  f)9  g)11  h)13

 

3.) Se considera pseudocodul alaturat:

citeste n (n>0)

citeste x (x>1)

dx; nn-1;

┌cat_timp n<>0 executa

|  citeste x(x>1)

|    ┌cat_timp d<>x executa

|      |  ┌daca x>0 atunci xx-d

|      |      | altfel dd-x

|      |      ▄

|      ||▄

|       n n-1

| ▄

scrie d

stop

a) Care va fi valoarea afisata pentru valoarea n=4 si pentru valorile successive ale lui x:18, 12, 24, 144.

b) Scrieti programul Pascal corespunzator algoritmului dat.

c)Dati un ezemplu de set de date de intrare format de valori distincte ,pentru care va fi afisata valoarea 10.

  1. d) Rescrieti programul folosind structuri repetitive conditionate posterior(repeat,until).

 

4.)Scrieti programul Pascal care transforma numarul din baza 2 in baza 10.

Numarul se da ca un sir de numere format din 0 si 1.

Ex: n=3 lungimea sirului de caractere

v=110 numarul citit

numarul in baza 10 va fii m=6

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s