Testul nr 8

1p 1) Variabila x este de tip real. Care dintre următoarele expresii C/C++ are valoarea 1 dacă şi numai dacă numărul real memorat în variabila x aparţine intervalului (5,8]?

a) (x<=8) && (x>5)

b) (x<=8) || (x>5)

c) (x<8) && (x>=5)

d) (x>8) || (x<=5)

1p 2) S-a notat cu x%y restul împărţirii numărului întreg x la numărul întreg nenul y şi cu [a] partea întreagă a numărului real a.
citeşte n (număr natural)
z<-0
p<-1
cât timp n>0 execută
c<-n%10
n<-[n/10]
dacă c%3=0 atunci
z<-z+p*(9-c)
p<-p*10
sf_daca
sf_cat_timp
scrie z

 a) 963

b) 962

c) 960

d) 964

 

1p 3) Se consideră o coadă în care iniţial au fost introduse, în această ordine, elementele cu valorile 1 şi 2:1-2. Se notează cu AD(x) operaţia prin care se adaugă elementul cu valoarea x în coadă şi cu EL operaţia prin care se elimină un element din coadă. Câte elemente va conţine coada în urma executării secvenţei de operaţii: AD(4);EL;EL;AD(5);EL;AD(3)?a) 5

b) 2

c) 1

d) 3

 

1p 4) Care este numărul maxim de componente conexe pe care le poate avea un graf neorientat cu 20 noduri şi 12 muchii?

a) 15

b) 6

c) 12

d) 10

3p 5)Să se creeze un program în limbajul C pentru rezolvarea ecuației de gradul al doilea pentru următoarele condiiții a lui delta:

a) delta <0;

b) delta=0;

c) delta>0.

Exemplu:

Date de intrare :  a=2 b= 4 c=4

Date de ieșire: Se va afisa mesajul ” Are soluții iraționale”

 

Timp de lucru: 50 minute.

Atenție! Toate cerințele sunt obligatorii și se acordă 3p din oficiu.

 

 

 

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s