Testul nr 12

2p 1.Indicaţi expresia care are valoarea true/1 dacă şi numai dacă numărul real memorat în variabila x se află în intervalul [-5,5]                                                         

Limbajul C/C++ 

 a)x*x-25<0  

b) 25-x*x>=0   

c) (5<=x)&&(x<=-5)

d) (x-5)*(x+5)>=0.                

 

3p 2.Se consideră algoritmul următor reprezentat în pseudocod:

S-a notat cu x%y restul împărţirii numărului întreg x la numărul întreg nenul y şi cu [a] partea întreagă a numărului real a.

citeşte n (număr natural)

z<-0; p<-1

┌cât timp n>0 execută

│ c<-n%10

│ n<-[n/10]

│┌dacă c%2=0 atunci

││ z<-z+p*(c+1)

││ p<-p*10

│└■

└■

scrie z

a)Ce valoare va fi afişată dacă se citește valoarea 1092744?

b)Scrieţi toate numere naturale, distincte, fiecare având exact două cifre, care pot fi citite pentru variabila n astfel încât să se afişeze valoarea 7. 

c)Scrieţi în pseudocod un algoritm, echivalent cu cel dat, în care să se înlocuiască structura cât timp…execută cu o structură repetitivă de alt tip.

d)Scrieţi programul Pascal/C/C++ corespunzător algoritmului dat. 

 

1p 3.Se consideră definite trei variabile de tip int: x, y şi z. O expresie C/C++ care are valoarea 1 dacă şi numai dacă x, y şi z au valori identice este:

a. x==y && x==z;

b. x==y==z;

c. x==y || x==z || y==z;

d. !( x!=y && x!=z).

3p 4. Se consideră algoritmul alăturat descris în pseudocod.

citeşte n (număr natural nenul) s<-0

{ pentru i<-1,n execută

a<-0

b<-1

j<-1

cât timp j>i execută

{  r<-2*b-a

a<-b

b<-r

j<-j+1

}

s<-s+b

}

scrie s

 

a) Scrieți numărul afişat în urma executării algoritmului dacă pentru n se citeşte valoarea 6.

b) Scrieți o valoare care poate fi citită pentru n astfel încât să se afişeze valoarea 55.

c) Scrieți în pseudocod un algoritm, echivalent cu cel dat, care să conțină o singură structură repetitivă.

d) Scrieți programul C/C++ corespunzător algoritmului dat.

 

Atenție! Timp de lucru 50 minute și se acordă 1p din oficiu.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s